What was done so far: - We have scaled our infrastructure. From this we notice improvements already. - Extra monitoring
We continue to monitor and will be strengthening our platform resilience to improve stability and minimize the impact of external network disruptions.
Posted Sep 02, 2026 - 17:01 CEST
Identified
Peppol network instabilities caused:
- Failed delivery of some invoices due to incorrect participant information. - Increased processing times and degraded API performance.
Current Status
- The routing issue has been resolved. Please resend invoices with status ERROR_CUSTOMER_NOT_REGISTERED. - We are scaling our infrastructure and strengthening platform resilience to improve stability and minimize the impact of external network disruptions.
We continue to monitor the situation closely and will provide further updates as necessary. We apologize for any inconvenience and thank you for your understanding.
Posted Sep 02, 2026 - 14:56 CEST
Update
We're experiencing performance issues. Our development is looking into the problem.
Posted Sep 02, 2026 - 11:48 CEST
Update
The issue is related to the planned maintenance at the Peppol SML between 09:00 and 11:30. All registration requests will be processed this night.
Posted Sep 02, 2026 - 10:14 CEST
Update
We are continuing to investigate this issue.
Posted Sep 02, 2026 - 09:59 CEST
Investigating
We are currently investigating this issue.
Posted Sep 02, 2026 - 09:49 CEST
This incident affects: Flowin API, Peppol SMP, Peppol Sending, and Peppol Registration.